
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">

<head id="ctl00_Head1"><title>
	Windows 10 và tương lai của ứng dụng UWP - PC World VN
</title><meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta http-equiv="Content-Language" content="VN" />
<meta name="distribution" content="Global"/>
<meta name="revisit-after" content="1 days"/>
<meta name="robots" content="FOLLOW,INDEX"/>
<meta name="title" content="Windows 10 và tương lai của ứng dụng UWP - PC World VN"/>
<meta name="Keywords" content="Microsoft, Thương Huyền, Universal Windows Platform, Windows 10, Windows 10 Creator, "/>
<meta name="Description" content="Với bản Creators Update, Microsoft cho phép phủ lên ứng dụng desktop định dạng Universal Windows Platform một cách dễ dàng. Đây phải chăng là bước tiến quan trọng để ứng dụng Windows 10 hiện đại hơn hay thừa nhận ứng dụng PC truyền thống là nền tảng của Windows?" /> <link rel="canonical" href="http://www.pcworld.com.vn/articles/cong-nghe/2017/08/1251727/windows-10-va-tuong-lai-cua-ung-dung-uwp/" /> <meta property="og:url" href="http://www.pcworld.com.vn/articles/cong-nghe/2017/08/1251727/windows-10-va-tuong-lai-cua-ung-dung-uwp/" /> <meta property="og:description" content="Với bản Creators Update, Microsoft cho phép phủ lên ứng dụng desktop định dạng Universal Windows Platform một cách dễ dàng. Đây phải chăng là bước tiến quan trọng để ứng dụng Windows 10 hiện đại hơn hay thừa nhận ứng dụng PC truyền thống là nền tảng của Windows?"/>
<meta name="Abstract" content="Với bản Creators Update, Microsoft cho phép phủ lên ứng dụng desktop định dạng Universal Windows Platform một cách dễ dàng. Đây phải chăng là bước tiến quan trọng để ứng dụng Windows 10 hiện đại hơn hay thừa nhận ứng dụng PC truyền thống là nền tảng của Windows?" /> <meta property="og:image" content="http://www.pcworld.com.vn/files/articles/2017/1251727/uwp-apps.png"/>
<meta name="author" content="Thương Huyền "/>
<meta name="copyright" content="© Bản quyền của Tạp chí Thế Giới Vi Tính - PC World VN"/>
<meta name="section" content="Tin bài"/>
<meta property="og:type" content="article" /><meta property="og:site_name" content="PC World VN | Tạp chí Công nghệ thông tin - Truyền thông" /><meta property="article:publisher" content="https://www.facebook.com/pcworldvietnam" /><meta property="article:author" content="https://www.facebook.com/pcworldvietnam" /><meta property="fb:pages" content="550578275063668" /><meta property="fb:app_id" content="335545929956156" /><meta property="fb:admins" content="100003732140022 " /><meta property="fb:admins" content="100003084092457" /><meta property="fb:admins" content="1044201498" /><meta property="fb:admins" content="553948590" /><meta name="wot-verification" content="3326aef53ef75f1a7dc0" /><link rel="alternate" type="application/rss+xml" title="PC WORLD VN RSS" href="http://m.pcworld.com.vn/rssfeed/" /><link rel="search" type="application/opensearchdescription+xml" title="Search PC WORLD VN" href="/opensearch.xml" /><link href="../../../../../../js/AutoComplete/jquery.autocomplete.css" rel="stylesheet" type="text/css" /><link href="../../../../../../App_Themes/Themes/style.css" rel="stylesheet" type="text/css" /><link href="../../../../../../App_Themes/Themes/media.css" rel="stylesheet" type="text/css" /><link href="../../../../../../App_Themes/PRESS/Controls.css" rel="stylesheet" type="text/css" /><link href="../../../../../../App_Themes/PRESS/ArticleStyle.css" rel="stylesheet" type="text/css" /><link href="../../../../../../js/highslide/highslide.css" rel="stylesheet" type="text/css" /><link href="../../../../../../js/datepicker/datepicker.css" rel="stylesheet" type="text/css" /><link href="../../../../../../js/galleria/galleriffic.css" rel="stylesheet" type="text/css" media="screen" /><link href="../../../../../../js/slider/style.css" rel="stylesheet" type="text/css" media="screen" />
	<!--
    <script src="/js/json.js" type="text/javascript"></script>
	-->
    <script src="/Handler/AdServerCaller.ashx?proxy" type="text/javascript"></script>
    <script src="/js/jquery-1.3.2.min.js" type="text/javascript"></script>
    <script src="/js/jquery/jquery.jcarousel.pack.js" type="text/javascript"></script>
    <script src="/js/jquery.qtip.min.js" type="text/javascript"></script>
    <script src="/js/galleria/jquery.galleriffic.min.js" type="text/javascript"></script>
    <script src="/js/jquery.marquee.js" type="text/javascript"></script>
    <script src="/js/datepicker/datepicker.js" type="text/javascript"></script>
    <script src="/js/galleria/jquery.galleria.js" type="text/javascript"></script>
    <script src="/js/jmetadata.js" type="text/javascript"></script>
    <script src="/js/jmedia.js" type="text/javascript"></script>
    <script src="/js/highslide/highslide-full.packed.js" type="text/javascript"></script>
    <script src="/js/common.js?r=2" type="text/javascript"></script>
    <script src="/js/jflash/jquery.jflash.js" type="text/javascript"></script>
    <script src="/js/AutoComplete/jquery.autocomplete.pack.js" type="text/javascript"></script>
    <script src="/js/slider/jquery-ui.min.js" type="text/javascript"></script>

	<link rel="apple-touch-icon-precomposed" sizes="57x57" href="/images/apple-touch-icon-57x57.png" /><link rel="apple-touch-icon-precomposed" sizes="114x114" href="/images/apple-touch-icon-114x114.png" /><link rel="apple-touch-icon-precomposed" sizes="72x72" href="/images/apple-touch-icon-72x72.png" /><link rel="apple-touch-icon-precomposed" sizes="144x144" href="/images/apple-touch-icon-144x144.png" /><link rel="apple-touch-icon-precomposed" sizes="60x60" href="/images/apple-touch-icon-60x60.png" /><link rel="apple-touch-icon-precomposed" sizes="120x120" href="/images/apple-touch-icon-120x120.png" /><link rel="apple-touch-icon-precomposed" sizes="76x76" href="/images/apple-touch-icon-76x76.png" /><link rel="apple-touch-icon-precomposed" sizes="152x152" href="/images/apple-touch-icon-152x152.png" /><link rel="icon" type="image/png" href="/images/favicon-196x196.png" sizes="196x196" /><link rel="icon" type="image/png" href="/images/favicon-96x96.png" sizes="96x96" /><link rel="icon" type="image/png" href="/images/favicon-32x32.png" sizes="32x32" /><link rel="icon" type="image/png" href="/images/favicon-16x16.png" sizes="16x16" /><link rel="icon" type="image/png" href="/images/favicon-128.png" sizes="128x128" /><meta name="application-name" content=" " /><meta name="msapplication-TileColor" content="#FFFFFF" /><meta name="msapplication-TileImage" content="/images/mstile-144x144.png" /><meta name="msapplication-square70x70logo" content="/images/mstile-70x70.png" /><meta name="msapplication-square150x150logo" content="/images/mstile-150x150.png" /><meta name="msapplication-wide310x150logo" content="/images/mstile-310x150.png" /><meta name="msapplication-square310x310logo" content="/images/mstile-310x310.png" />
    
		
    <!-- Start Alexa Certify Javascript -->
    <script type="text/javascript">
        _atrk_opts = { atrk_acct: "Bueqj1aAkN00MZ", domain: "pcworld.com.vn", dynamic: true };
        (function () { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://d31qbv1cthcecs.cloudfront.net/atrk.js"; var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(as, s); })();
    </script>
    <noscript>
        <img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=Bueqj1aAkN00MZ" style="display: none"
            height="1" width="1" alt="" /></noscript>
    <!-- End Alexa Certify Javascript -->
    <script language="javascript" type="text/javascript">
        if (location != top.location) top.location = location;
        if (window.location.pathname == "/") {
            document.title = "PC World VN - Thế Giới Vi Tính | Tạp chí Công nghệ thông tin - Truyền thông";
        }
    </script>
	<script type="text/javascript">
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
		ga('create', 'UA-401587-1', 'auto');
		ga('require', 'displayfeatures');
		ga('send', 'pageview');
	</script>
    
    <script type="text/javascript">
        var href = document.location.href;
        var string = href.split("/");
        i = string.length - 1;
        f = string[0].length + string[1].length + string[2].length + 2;
        var path = href.substring(f, href.length);
        //console.log("http://m.pcworld.com.vn" + path);
        var ua = navigator.userAgent.toLowerCase(),
                  platform = navigator.platform.toLowerCase(),
                  UA = ua.match(/(opera|ie|firefox|chrome|version)[\s\/:]([\w\d\.]+)?.*?(safari|version[\s\/:]([\w\d\.]+)|$)/) || [null, 'unknown', 0],
                  mode = UA[1] == 'ie' && document.documentMode;

        var Browser = {
            extend: Function.prototype.extend,
            name: (UA[1] == 'version') ? UA[3] : UA[1],
            version: mode || parseFloat((UA[1] == 'opera' && UA[4]) ? UA[4] : UA[2]),
            Platform: {
                name: ua.match(/ip(?:ad|od|hone)/) ? 'ios' : (ua.match(/(?:webos|android|bada|symbian|palm|blackberry)/) || platform.match(/mac|win|linux/) || ['other'])[0]
            },
            Features: {
                xpath: !!(document.evaluate),
                air: !!(window.runtime),
                query: !!(document.querySelector),
                json: !!(window.JSON)
            },
            Plugins: {}
        };
        if (Browser.Platform.name == 'android' || Browser.Platform.name == 'ios' || Browser.Platform.name == 'webos' || Browser.Platform.name == 'bada' || Browser.Platform.name == 'symbian' || Browser.Platform.name == 'palm' || Browser.Platform.name == 'blackberry') {
            window.location = "http://m.pcworld.com.vn" + path;
        }
    </script>
	<script type="text/javascript" async defer
	  src="https://apis.google.com/js/platform.js?publisherid=106797699705859110262">
	</script>	
	<script type="application/ld+json">
		{
			"@context": "http://schema.org",
			"@type": "WebSite",
			"url": "http://www.pcworld.com.vn/ ",
			"potentialAction": {
			"@type": "SearchAction",
			"target": "http://www.pcworld.com.vn/search/?q={search_term}",
			"query-input": "required name=search_term"
			}
		}
	</script>	
	
</head>
<body>
    <a href="https://plus.google.com/106797699705859110262" rel="publisher"></a>
    <form name="aspnetForm" method="post" id="aspnetForm">
<input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="/wEPDwUENTM4MWQYAQUeX19Db250cm9sc1JlcXVpcmVQb3N0QmFja0tleV9fFgEFGGN0bDAwJGN0JHNlJHJkNCRidFNlYXJjaMUHU6i0ZJVOnWIuQHrBXaiAsclh" />

<link href="/js/superfish/css/superfish.css" rel="stylesheet" type="text/css" /><script src="/js/superfish/js/hoverintent.js" type="text/javascript"></script><script src="/js/superfish/js/superfish.js" type="text/javascript"></script><script src="/js/superfish/js/supersubs.js" type="text/javascript"></script><script src="/js/jquery.jbreadcrumb.min.js" type="text/javascript"></script>
<script src="/ScriptResource.axd?d=ZS5hhmjpLaFO4j2k0kIjWtvlNxPnCIWNdEAg5a_avru5TVZN-V80ykr3qj4AlE2SNMxM7cX6H06-VlbQ7AkEZGbpvYe7NDnwWnD5rrs7uVcCEljEHq4RycBpFD9tNCc_jrBrJMN6766OIyR5x3MpdwG0eE81&amp;t=ffffffffbcb9b94a" type="text/javascript"></script>
<script src="/SupportMethods.asmx/js" type="text/javascript"></script>
<input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="CA0B0334" />
<input type="hidden" name="__EVENTVALIDATION" id="__EVENTVALIDATION" value="/wEWAwLo04+LBwKh9PzcDgLGssrOASaoMUhZNEiDsKdeMmlxk00X8iyO" />
        
        <div class="wrapper">
            <div id="content">
                
                
<div class="header-global-top">

<div class="tool-top">
    <ul>
        <li class="left">PC World VN - ISSN:1859 - 1817</li>
        <li class="right">
            <a class="testlab" href="http://www.pcworld.com.vn/testlab">Test Lab</a>
			<a class="facebook" href="https://www.facebook.com/pcworldvietnam/" target="_blank"></a>
			<a class="twitter" href="https://twitter.com/pcworldvietnam/" target="_blank"></a>
			<a class="googleplus" href="http://plus.google.com/+PCWorldVN/" target="_blank"></a>
			<a class="rss" href="http://www.pcworld.com.vn/articles.rss" target="_blank"></a>
            <a class="game" href="/articles/game/">Thế Giới Game</a>
        </li>
    </ul>
    <div class="clear"></div>
</div>
</div>
<div class="header-global">
    <ul>
        <li class="l">
            <div class="pc-logo" style="cursor:pointer" onClick="javaScript:window.location='/';">			
            </div>
        </li>
        <li class="adv-728-90">
            <div class="pc-adv-local-728-90" id="adv-banner">
                <div align="center">
<div data-glade data-ad-unit-path="/218817569/pcworld.com.vn-article-728-90-01" height="90" width="728"></div>
<script async='async' src='https://securepubads.g.doubleclick.net/static/glade.js'></script>
</div>
            </div>
        </li>
    </ul>
</div>


<div class="header-navigation">
    <div id="main-menu-container">
        <div id="main-menu">
            <ul>
                <li  >
<a  class="item-home" href="/"><span></span></a>
<span class="sep"></span>
</li>
<li  >
<a href="/articles/tin-tuc/"><span>Tin tức</span></a>
<span class="sep"></span>
</li>
<li  >
<a href="/articles/san-pham/"><span>Sản phẩm</span></a>
<span class="sep"></span>
</li>
<li class=" current active " >
<a href="/articles/cong-nghe/"><span>Công nghệ</span></a>
<span class="sep"></span>
</li>
<li  >
<a href="/articles/kinh-doanh/"><span>Kinh Doanh</span></a>
<span class="sep"></span>
</li>
<li  >
<a  class="" href="/testlab"><span>Test Lab</span></a>
<span class="sep"></span>
</li>
<li  >
<a href="/articles/game/"><span>Giải trí</span></a>
<span class="sep"></span>
</li>
<li  >
<a  class="" href="/pages/e-paper/"><span>E-Paper</span></a>
<span class="sep"></span>
</li>
<li  >
<a  class="" href="http://eshop.pcworld.com.vn/"><span>Mua Tạp Chí</span></a>
<span class="sep"></span>
</li>

                <li>
                    <input name="ctl00$ct$se$rd4$tbSearchText" type="text" id="ctl00_ct_se_rd4_tbSearchText" class="searchtextbox" onfocus="SearchOnFocus(this)" onblur="SearchOnBlur(this)" />
                    <input type="image" name="ctl00$ct$se$rd4$btSearch" id="ctl00_ct_se_rd4_btSearch" src="/App_Themes/Themes/Images/icon-search.png" onclick="return Search();" border="0" style="cursor: pointer; vertical-align: middle;" />
                </li>
            </ul>
        </div>
        <div style="clear: both">
        </div>
    </div>
    <div class="clear-all">
    </div>
</div>
<div id="main-menu-lv2-container">
    <div id="main-menu-lv2">
        <div class="sub hide ">
<a onclick=DatLamTrangChu(this) class='fist ' href='javascript:void(0)' >Đặt làm trang chủ</a><a  class='' href='/pages/thong-tin-toa-soan/' >Giới thiệu</a><a  class='' href='/lien-he/' >Liên hệ</a><a  class='' href='/datbao/' >Đặt mua tạp chí</a><a  class='' href='/quang-cao/' >Quảng cáo</a></div>
<div class=" sub  hide ">
<a class="fist " href='/articles/tin-tuc/tin-quoc-te/' >Tin nước ngoài</a><a class="" href='/articles/tin-tuc/tin-trong-nuoc/' >Tin trong nước</a><a class="" href='/articles/tin-tuc/binh-luan/' >Bình luận</a>

</div>
<div class=" sub  hide ">
<a class="fist " href='/articles/san-pham/di-dong/' >Di động</a><a class="" href='/articles/san-pham/may-xach-tay/' >Laptop</a><a class="" href='/articles/san-pham/may-anh-so/' >Máy ảnh</a><a class="" href='/articles/san-pham/the-gioi-may-tinh/' >Máy tính</a><a class="" href='/articles/san-pham/he-dieu-hanh/' >Hệ điều hành</a><a class="" href='/articles/san-pham/may-in/' >Máy in</a><a class="" href='/articles/san-pham/dia-cung-usb-the-nho/' >Đĩa cứng - USB</a><a class="" href='/articles/san-pham/bo-mach-chu/' >Bo mạch chủ</a><a class="" href='/articles/san-pham/card-do-hoa/' >Card đồ họa</a><a class="" href='/articles/san-pham/bo-xu-ly/' >Bộ xử lý</a><a class="" href='/articles/san-pham/thanh-phan-may-tinh/' >Thành phần máy tính</a><a class="" href='/articles/san-pham/thiet-bi-mang/' >Thiết bị mạng</a><a class="" href='/articles/san-pham/may-chu/' >Máy chủ</a><a class="" href='/articles/san-pham/dien-tu-tieu-dung/' >Điện tử - Tiêu dùng</a><a class="" href='/articles/san-pham/phan-mem/' >Phần mềm</a>
<a   href='/articles/san-pham/' >Xem thêm...</a>
</div>
<div class=" sub  current hide ">
<a class="fist " href='/articles/cong-nghe/cong-nghe/' >Công nghệ</a><a class="" href='/articles/cong-nghe/ung-dung/' >Ứng dụng</a><a class="" href='/articles/cong-nghe/lam-the-nao/' >Làm thế nào</a><a class="" href='/articles/cong-nghe/an-ninh-mang/' >An ninh mạng</a><a class="" href='/articles/cong-nghe/song-va-cong-nghe/' >Sống và công nghệ</a>

</div>
<div class=" sub  hide ">
<a class="fist " href='/articles/kinh-doanh/quan-tri/' >Quản trị</a><a class="" href='/articles/kinh-doanh/giai-phap/' >Giải pháp</a><a class="" href='/articles/kinh-doanh/nha-nuoc/' >Nhà nước</a>

</div>
<div class="sub hide ">
<!-- -->
</div>
<div class=" sub  hide ">


</div>
<div class="sub hide ">
<!-- -->
</div>
<div class="sub hide ">
<!-- -->
</div>

        <div style="clear: both">
        </div>
    </div>
</div>
<div class="clear-all">
</div>

<script type="text/javascript">
    var main_menu__tm = null;
    var main_menu_lv2_focus = false;
    $(function() {
        $('#main-menu ul li').bind('mouseenter mouseleave', function(ev) {
            var $li = (ev.target.tagName != 'LI' ? $(ev.target).parents('li') : $(ev.target));
            var $all = $('#main-menu ul li');
            var idx = $all.index($li);
            if (ev.type == 'mouseenter') {
                $all.removeClass('current');
                $li.addClass('current');
                $sub_menu = $('#main-menu-lv2 div').addClass('hide').eq(idx);
                main_menu__align($sub_menu, $li);
                if (main_menu__tm) clearTimeout(main_menu__tm);
                main_menu__tm = null;
            } else {
                if (main_menu__tm) clearTimeout(main_menu__tm);
                main_menu__tm = setTimeout('main_menu__check()', 1500);
            }
        });
        $('#main-menu-lv2').bind('mouseenter mouseleave', function(ev) {
            if (ev.type == 'mouseenter') {
                if (main_menu__tm) clearTimeout(main_menu__tm);
                main_menu__tm = null;
            } else {
                main_menu__tm = setTimeout('main_menu__check()', 1500);

            }
        });
        $sub_menu = $('#main-menu-lv2 div.current');
        $li = $('#main-menu ul li.active');
        main_menu__align($sub_menu, $li);
    });
    function main_menu__align($sub_menu, $li) {
        if ($sub_menu.attr('checked')) {
            $sub_menu.removeClass('hide');
            return;
        }
        var cw = $('#main-menu').outerWidth() - 15;
        var w = $sub_menu.outerWidth(true);
        var x = ($li.position() != null ? $li.position().left : 0 + ($li.width() / 2)) - (w / 2);
        if (x < 15) x = 15; else if (x + w > cw) x = cw - w;
        $sub_menu.css('left', Math.round(x) + 'px');
        $sub_menu.removeClass('hide');
        $sub_menu.attr('checked', '1');
    }
    function main_menu__check() {

        main_menu__tm = null;
        var $all = $('#main-menu ul li');
        var $cur = $all.filter('li.current');
        var $act = $all.filter('li.active');
        if ($cur.hasClass('active')) return;
        $cur.removeClass('current');
        $act.addClass('current');
        $('#main-menu-lv2 div').addClass('hide').eq($all.index($act)).removeClass('hide');
    }
    function DatLamTrangChu(i) {
        if (window.sidebar) {
            if (window.netscape) {
                try {
                    netscape.security.PrivilegeManager.enablePrivilege("UniversalXPConnect");
                }
                catch (e) {
                    alert("this action was aviod by your browser，if you want to enable，please enter about:config in your address line,and change the value of signed.applets.codebase_principal_support to true");
                }
            }
        }
        if (document.all) {
            i.style.behavior = 'url(#default#homepage)';
            i.setHomePage('http://www.pcworld.com.vn');
        }
    }

</script>

<script type="text/javascript" language="javascript">
    function Search() {
        var text = $("#ctl00_ct_se_rd4_tbSearchText").attr("value");
        if (text == null || text == '' || text == 'Từ khóa tìm kiếm')
            $("#ctl00_ct_se_rd4_tbSearchText").focus();
        else {
            window.location = "http://www.pcworld.com.vn/search/?q='" + text;
        }
        return false;
    }
</script>


<div class="wrapper-content">
    <div class="pc-adv-local-2">
        <div class="editon-area">
            <div>
	<a href="http://eshop.pcworld.com.vn/products/1432-5g-bao-gi.aspx?utm_source=pcworld-desktop&amp;utm_medium=referral&amp;utm_campaign=eshop" target="_blank">
	<img src="http://eshop.pcworld.com.vn:8081/Data/Images/ProductVariants/TGVT-A/2017/Bia_A1708_S.jpg" width="65" height="90" alt="5G Bao giờ" />
	</a>
	<a href="http://eshop.pcworld.com.vn/products/1431-smartphone-selfie.aspx?utm_source=pcworld-desktop&amp;utm_medium=referral&amp;utm_campaign=eshop" target="_blank">
	<img src="http://eshop.pcworld.com.vn:8081/Data/Images/ProductVariants/TGVT-A/2017/Bia_A1707_S.jpg" width="65" height="90" alt="SMARTPHONE SELFIE" />
	</a>
	<a href="http://eshop.pcworld.com.vn/products/1430-tri-nghim-h-cng-ngh.aspx?utm_source=pcworld-desktop&amp;utm_medium=referral&amp;utm_campaign=eshop" target="_blank">
	<img src="http://eshop.pcworld.com.vn:8081/Data/Images/ProductVariants/TGVT-A/2017/Bia_A1706_240.jpg" width="65" height="90" alt="TRẢI NGHIỆM HÈ CÔNG NGHỆ" />
	</a>
</div>
        </div>
        <div class="advtop-area-2">
            <div class="ct-adv">
                <div>
<div data-glade data-ad-unit-path="/218817569/pcworld.com.vn-article-728-90-02" height="90" width="728"></div>
<script async='async' src='https://securepubads.g.doubleclick.net/static/glade.js'></script></div>
            </div>
        </div>
        <div style="clear: both">
        </div>
    </div>
    <div class="detail">
        <div class="left">
            <ul class="line-box-rounder">

                <li class="ct-2">
                    

<div class="breadCrumbHolder module">
    <table border="0" cellpadding="0" cellspacing="0" width="100%'">
        <tr>
            <td width="70%" align="left">
                <div id="articleBreadCrumb" class="breadCrumb module">
                    <ul>
                        <li><a href="/">PC World VN</a></li>
                        <li><a href="/articles/cong-nghe/">Công nghệ</a></li>
                    </ul>
                </div>
            </td>
            <td width="30%" align="right">
                <!-- AddThis Button BEGIN -->
				<div id='div_addThis'></div>			
                <!-- AddThis Button END -->
            </td>
        </tr>
    </table>
</div>
<div class="clear-all">
</div>
<script type="text/javascript">
    jQuery(document).ready(function() {
        jQuery("#articleBreadCrumb").jBreadCrumb();
    })
</script>



<div class="ar-content">
    <table border="0" cellpadding="0" cellspacing="0"  style="border-collapse:collapse">
        <tr>
            <td>
                <div class="date">
                    Thứ Tư, 30/08/2017 09:41 (GMT+7)</div>
            </td>
            <td>
                <div class="source">
                </div>
            </td>
        </tr>
        <tr>
            <td width="535px">
                <div class="subtitle">
                    </div>
                <div class="title">
                    <h1>
                        Windows 10 và tương lai của ứng dụng UWP
                    </h1>
                </div>
            </td>

        </tr>
        <tr>
            <td class="keyword">
                <div class="author">Thương Huyền </div>
            </td>
            <td>
                <div class="toolbar">
                    <a class="button printer" target="_blank" title="Bản in" href="/ArticlePrint.aspx?ArticleId=1251727">
                    </a><a class="button email thickbox" href="/article-sendmail-iframe.aspx?ArticleId=1251727&keepThis=true&TB_iframe=true&height=300&width=400"
                        title="Gởi liên kết bài này qua E-mail"></a><a class="button star" href="/article-add-to-fav.aspx?articleId=1251727"
                            title="Đánh dấu bài hay"></a><a class="button zoomminus" href="#" title="Thu nhỏ cỡ chữ đọc bài">
                            </a><a class="button zoomplus" href="#" title="Phóng to cỡ chữ đọc bài">
                    </a>
                </div>
                <div class="clear-all">
                </div>
            </td>
        </tr>
    </table>
    <div class="line">
    </div>
    
    <div id="ar-paragraph" style="display:none;">
        <span class="header">Mục lục </span>
        <ul class="sf-menu">
            <li><a class="sf-with-ul" href="#a">
                Windows 10 và tương lai của ứng dụng UWP<span class="sf-sub-indicator"> &#187;</span></a>
                <ul>
                    
                </ul>
            </li>
        </ul>
        <div style="clear: both">
        </div>
    </div>
    
    <div class="summary" style="margin-bottom: 7px">
        <!-- <font color="#808080">TGVT-PCW VN&nbsp;-&nbsp;</font> -->Với bản Creators Update, Microsoft cho phép phủ lên ứng dụng desktop định dạng Universal Windows Platform một cách dễ dàng. Đây phải chăng là bước tiến quan trọng để ứng dụng Windows 10 hiện đại hơn hay thừa nhận ứng dụng PC truyền thống là nền tảng của Windows?
    </div>
    <div class="html" id="ar-content-html">
		<ul><li><a href="/articles/san-pham/bo-xu-ly/2017/08/1252435/hp-sap-tung-laptop-dung-bo-xu-ly-intel-coffee-lake/">HP sắp tung laptop d&ugrave;ng bộ xử l&yacute; Intel Coffee Lake</a></li><li><a href="/articles/cong-nghe/lam-the-nao/2017/08/1252369/kich-hoat-ma-pin-tu-huy-tren-windows-10/">K&iacute;ch hoạt m&atilde; PIN &lsquo;tự hủy&rsquo; tr&ecirc;n Windows 10</a></li><li><a href="/articles/cong-nghe/cong-nghe/2017/05/1251259/he-dieu-hanh-32-bit-va-64-bit-dau-la-su-khac-biet/">Hệ điều h&agrave;nh 32-bit v&agrave; 64-bit:  Đ&acirc;u l&agrave; sự kh&aacute;c biệt</a></li><li><a href="/articles/cong-nghe/cong-nghe/2016/08/1249319/nhung-he-dieu-hanh-danh-cho-iot-trong-tuong-lai/">Những hệ điều h&agrave;nh d&agrave;nh cho IoT trong tương lai </a></li><li><a href="/articles/cong-nghe/cong-nghe/2017/04/1250887/cuoc-chay-dua-ve-chip-cho-tri-tue-nhan-tao/">Cuộc chạy đua về chip cho tr&iacute; tuệ nh&acirc;n tạo</a></li></ul><p><a href="http://www.pcworld.com.vn/tags/?kw=Windows%2010">Windows 10</a> (cũng như Windows 8 trước đ&acirc;y) kh&ocirc;ng đơn thuần l&agrave; một phi&ecirc;n bản mới của hệ điều h&agrave;nh Windows. Cuộc c&aacute;ch t&acirc;n n&agrave;y c&ograve;n tạo ra nền tảng Windows d&ugrave;ng chung <a href="http://www.pcworld.com.vn/articles/cong-nghe/cong-nghe/2015/09/1242489/universal-gay-kho-cho-nha-phat-trien-windows-10/">Universal Windows Platform (UWP)</a>, cho ph&eacute;p c&aacute;c nh&agrave; ph&aacute;t triển viết ứng dụng một lần để chạy tr&ecirc;n nhiều loại thiết bị, từ PC, tablet, smarphone cho đến Xbox v&agrave; HoloLens. Đ&acirc;y l&agrave; một phần rất quan trọng trong chiến lược &ldquo;One Windows&rdquo; trong hệ sinh th&aacute;i <a href="http://www.pcworld.com.vn/tags/?kw=Windows%2010">Windows 10</a> của Microsoft.</p><table class="ar-image-center" align="center" cellpadding="0" cellspacing="0"><tbody><tr><td><a class="lightbox-zoom" href="/files/articles/2017/1251727/h1-34-large.png" desc=""><img class="ar-photo" style="width: 600px; height=385px" src="/files/articles/2017/1251727/h1-34.png" alt=""></a></td></tr></tbody></table><p>Những ứng dụng nền tảng UWP n&agrave;y, c&ograve;n gọi l&agrave; ứng dụng &lsquo;universal&rsquo; (c&aacute;c phi&ecirc;n bản trước l&agrave; ứng dụng WinRT, Metro, Modern UI v&agrave; Store), c&oacute; quyền khai th&aacute;c c&aacute;c t&iacute;nh năng nền tảng mới như &ocirc; th&ocirc;ng tin động (live tile) tr&ecirc;n menu Start, nhập liệu bằng b&uacute;t số (ink input), l&agrave;m việc với Cortana v&agrave; tạo ra c&aacute;c th&ocirc;ng b&aacute;o trong <a href="http://www.pcworld.com.vn/tags/?kw=Action+Center">Action Center</a>. Nhưng ch&uacute;ng cũng c&oacute; những mặt hạn chế, v&agrave; những ngờ vực về t&iacute;nh <a href="http://www.pcworld.com.vn/tags/?kw=b%E1%BA%A3o+m%E1%BA%ADt">bảo mật</a>, độ tin cậy v&agrave; thời lượng pin.</p><p>C&aacute;c ứng dụng UWP tr&ecirc;n Windows 10 cũng chạy t&aacute;ch biệt kiểu sanbox như với c&aacute;c hệ điều h&agrave;nh di động tr&ecirc;n <a href="http://www.pcworld.com.vn/tags/?kw=smartphone">smartphone</a>. Ch&uacute;ng kh&ocirc;ng l&agrave;m thay đổi hẳn m&ocirc;i trường Windows khi được c&agrave;i v&agrave;o, thay v&agrave;o đ&oacute; sử dụng c&aacute;c tập tin hệ thống v&agrave; registry ảo n&ecirc;n kh&ocirc;ng xung đột với ứng dụng kh&aacute;c khi chạy, v&agrave; bạn dễ d&agrave;ng gỡ bỏ ch&uacute;ng ho&agrave;n to&agrave;n. File c&agrave;i đặt AppX c&oacute; thể được cập nhật li&ecirc;n tục để cung cấp t&iacute;nh năng mới cho ứng dụng, nhờ đ&oacute; người d&ugrave;ng kh&ocirc;ng c&ograve;n bị l&agrave;m phiền với những y&ecirc;u cầu n&acirc;ng cấp l&ecirc;n phi&ecirc;n bản ứng dụng mới.</p><p>C&aacute;c ứng dụng muốn truy cập v&agrave;o phần cứng như microphone v&agrave; webcam phải được cấp quyền, v&agrave; ch&uacute;ng kh&ocirc;ng thể truy cập to&agrave;n bộ hệ thống tập tin, do vậy ứng dụng độc hại kh&ocirc;ng thể g&acirc;y ra nhiều thiệt hại. Nếu đang chạy trong chế độ nền, ứng dụng UWP c&oacute; thể bị đ&oacute;ng ngay lập tức nếu hệ thống cần th&ecirc;m bộ nhớ.&nbsp;</p><p>Ứng dụng UWP sử dụng c&aacute;c API mới th&ecirc;m v&agrave;o cho <a href="http://www.pcworld.com.vn/articles/cong-nghe/lam-the-nao/2017/08/1252364/tuy-bien-cu-chi-touchpad-tren-windows-10/">Windows 10</a>, nhiều API trong số đ&oacute; vẫn c&oacute; thể được c&aacute;c ứng dụng desktop truyền thống sử dụng. Định dạng đ&oacute;ng g&oacute;i AppX của ứng dụng UWP cũng được sử dụng bởi Windows Server Apps; điều đ&oacute; quan trọng với Nano Server v&igrave; tr&ecirc;n đ&oacute; bạn kh&ocirc;ng thể chạy tr&igrave;nh c&agrave;i đặt GUI truyền thống như c&aacute;ch vẫn d&ugrave;ng cho nhiều ứng dụng m&aacute;y chủ, cũng nhờ thế c&aacute;c bản c&agrave;i tr&ecirc;n m&aacute;y chủ <a href="http://www.pcworld.com.vn/tags/?kw=Windows+Server+2016">Windows Server 2016</a> &ldquo;sạch&rdquo; hơn v&igrave; AppX kh&ocirc;ng hỗ trợ t&ugrave;y chỉnh.</p><p>Đang c&oacute; sự gia tăng c&aacute;c c&ocirc;ng cụ tạo ứng dụng UWP &ndash; từ hệ thống ph&aacute;t triển đa nền tảng Xamarin của <a href="http://www.pcworld.com.vn/tags/?kw=Microsoft">Microsoft</a> cho đến c&ocirc;ng cụ nguồn mở UWP Community Toolkit. Microsoft gần đ&acirc;y đ&atilde; hợp t&aacute;c với Telerik để kiểm so&aacute;t m&atilde; nguồn mở UWP cho c&aacute;c phần tử giao diện người d&ugrave;ng quan trọng từ c&aacute;c c&ocirc;ng cụ quen thuộc như kiểm so&aacute;t lưới hiển thị dữ liệu, form dữ liệu v&agrave; biểu đồ, cho tới điều khiển m&agrave;n h&igrave;nh cảm ứng v&agrave; xoay để sử dụng với &nbsp;phụ kiện Surface Dial của Microsoft. Nhờ vậy, việc ph&aacute;t triển ứng dụng UWP sẽ dễ d&agrave;ng v&agrave; đỡ tốn thời gian hơn.&nbsp;</p><p>Việc mở cơ sở dữ liệu những thiếu s&oacute;t kỹ thuật đối với UWP, trong đ&oacute; c&oacute; cả c&aacute;c t&iacute;nh năng đang trong qu&aacute; tr&igrave;nh ph&aacute;t triển, đem lại c&aacute;i nh&igrave;n r&otilde; r&agrave;ng hơn cho c&aacute;c nh&agrave; ph&aacute;t triển về kế hoạch của <a href="http://www.pcworld.com.vn/articles/cong-nghe/lam-the-nao/2017/07/1252264/thu-thuat-dong-vinh-vien-tai-khoan-microsoft/">Microsoft</a>. &nbsp;</p><table class="ar-image-center" align="center" cellpadding="0" cellspacing="0"><tbody><tr><td><a class="lightbox-zoom" href="/files/articles/2017/1251727/h2-27-large.png" desc=""><img class="ar-photo" style="width: 600px; height=338px" src="/files/articles/2017/1251727/h2-27.png" alt=""></a></td></tr></tbody></table><p><strong>Desktop Bridge &ndash; cầu nối sang UWP</strong></p><p>C&oacute; nhiều l&yacute; do cho thấy Microsoft đang gặp kh&oacute; khăn trong việc thuyết phục c&aacute;c nh&agrave; ph&aacute;t triển ứng dụng doanh nghiệp chuyển sang <a href="http://www.pcworld.com.vn/articles/cong-nghe/cong-nghe/2015/09/1242489/universal-gay-kho-cho-nha-phat-trien-windows-10/">nền tảng UWP</a>.&nbsp;</p><p>Ứng dụng UWP chỉ chạy tr&ecirc;n Windows 10, v&agrave; hệ điều h&agrave;nh mới n&agrave;y th&igrave; &nbsp;vẫn chưa phổ biến trong m&ocirc;i trường doanh nghiệp. Nicholas McQuire, ph&oacute; gi&aacute;m đốc nghi&ecirc;n cứu mảng doanh nghiệp của h&atilde;ng ph&acirc;n t&iacute;ch CCS Insight c&ograve;n cho rằng, c&aacute;c doanh nghiệp vẫn chưa nhận thức được những lợi thế của UWP, gi&aacute; trị ra sao trong những trường hợp cụ thể n&agrave;o. Th&ecirc;m r&agrave;o cản nữa l&agrave; phải viết lại từ đầu những ứng dụng desktop đ&atilde; c&oacute;, trong khi đ&oacute; nh&igrave;n chung vẫn c&ograve;n qu&aacute; nhiều bất cập trong việc ph&aacute;t triển ứng dụng di động cho doanh nghiệp. Ngay như Microsoft cũng thiếu sự tập trung v&agrave;o di động những năm trước đ&acirc;y.</p><p>Doanh nghiệp đang d&ugrave;ng ứng dụng .NET v&agrave; Win32, v&agrave; dĩ nhi&ecirc;n họ vẫn muốn tiếp tục sử dụng ch&uacute;ng. Để khuyến kh&iacute;ch doanh nghiệp sớm đến với UWP, năm ngo&aacute;i Micrsoft ph&aacute;t h&agrave;nh c&ocirc;ng cụ <a href="http://www.pcworld.com.vn/articles/san-pham/he-dieu-hanh/2017/07/1251978/moi-dieu-can-biet-ve-windows-10-s/">Desktop Bridge</a> chuyển đổi ứng dụng cũ sang UWP (ban đầu c&oacute; t&ecirc;n Project Centennial, về sau được giới thiệu l&agrave; Desktop App Converter). C&ocirc;ng cụ chuyển đổi phủ một lớp l&ecirc;n ứng dụng cũ để tr&ocirc;ng giống như ứng dụng UWP bằng c&aacute;ch xem x&eacute;t những nh&aacute;nh registry v&agrave; c&aacute;c tập tin hệ thống m&agrave; ch&uacute;ng thay đổi v&agrave; ảo h&oacute;a những thay đổi đ&oacute;.</p><p>Với bản <a href="http://www.pcworld.com.vn/tags/?kw=windows+10+Creator">Creators Update</a>, ứng dụng desktop được chuyển đổi sẽ khai th&aacute;c được những c&ocirc;ng nghệ mới như b&uacute;t vẽ v&agrave; <a href="http://www.pcworld.com.vn/tags/?kw=Cortana">Cortana</a>, thậm ch&iacute; cả Microsoft Bot Framework, v&igrave; ch&uacute;ng được quyền truy cập nhiều API hơn. Một lựa chọn mới hữu &iacute;ch kh&aacute;c nữa l&agrave; bạn c&oacute; thể viết ứng dụng Desktop Bridge m&agrave; c&oacute; thể khởi chạy khi hệ điều h&agrave;nh được nạp.</p><p>Desktop App Converter hiện đ&atilde; c&oacute; mặt tr&ecirc;n cửa h&agrave;ng <a href="http://www.pcworld.com.vn/tags/?kw=Windows+Store">Windows Store</a> sẵn s&agrave;ng cho c&aacute;c nh&agrave; ph&aacute;t triển tải về. V&agrave; c&aacute;c c&ocirc;ng cụ c&agrave;i đặt chuẩn của Windows, Install Shield, WiX v&agrave; bộ c&agrave;i Advanced Installer, tất cả đều đ&atilde; c&oacute; thể l&agrave;m việc với bộ chuyển đổi, do vậy nh&agrave; ph&aacute;t triển c&oacute; thể tạo ứng dụng chuyển đổi như một phần của c&ocirc;ng việc th&ocirc;ng thường.</p><p>Kh&aacute;c với ứng dụng UWP chuẩn, ứng dụng UWP chuyển đổi kh&ocirc;ng chạy trong sanbox, v&agrave; c&oacute; những khả năng m&agrave; ứng dụng UWP chuẩn kh&ocirc;ng c&oacute;, chẳng hạn như truy cập to&agrave;n bộ hệ thống tập tin. Ch&uacute;ng kh&ocirc;ng tự c&agrave;i tr&igrave;nh điều khiển nhưng c&oacute; thể l&agrave;m việc với c&aacute;c tr&igrave;nh điều khiển hiện c&oacute; để truy cập tới phần cứng, cơ sở dữ liệu v&agrave; c&aacute;c API mạng. D&ugrave; c&oacute; nhiều quyền nhưng cơ chế truy cập tập tin hệ thống v&agrave; <a href="http://www.pcworld.com.vn/tags/?kw=registry">registry</a> ảo gi&uacute;p n&acirc;ng cao độ tin cậy.</p><p>Đ&oacute; l&agrave; điều hấp dẫn nhất đối với c&aacute;c nh&agrave; ph&aacute;t triển ứng dụng doanh nghiệp, theo nh&agrave; ph&acirc;n t&iacute;ch Steve Kleynhans của h&atilde;ng nghi&ecirc;n cứu thị trường Gartner. &Ocirc;ng chia sẻ, &iacute;t c&oacute; kh&aacute;ch h&agrave;ng của h&atilde;ng hứng th&uacute; với việc viết lại ứng dụng của họ dưới dạng UWP để chạy tr&ecirc;n mọi thiết bị. Thay v&agrave;o đ&oacute; doanh nghiệp ng&agrave;y nay th&iacute;ch những ứng dụng đa nền tảng dựa tr&ecirc;n <a href="http://www.pcworld.com.vn/tags/?kw=tr%C3%ACnh+duy%E1%BB%87t">tr&igrave;nh duyệt</a>. Đ&acirc;y l&agrave; xu hướng ch&iacute;nh đối với c&aacute;c ứng dụng desktop chứ kh&ocirc;ng phải l&agrave; viết lại ch&uacute;ng th&agrave;nh dạng UWP. &Ocirc;ng cho rằng, điều doanh nghiệp thực sự quan t&acirc;m l&agrave; khả năng đ&oacute;ng g&oacute;i ứng dụng tự phục vụ v&agrave; ph&acirc;n phối ch&uacute;ng qua Windows Store.</p><p>Theo Steve th&igrave; Desktop Bridge nh&igrave;n chung đ&atilde; đ&aacute;p ứng những g&igrave; kh&aacute;ch h&agrave;ng muốn, tạo cho họ cơ hội đ&oacute;ng g&oacute;i phần lớn ứng dụng cũ, đưa ch&uacute;ng l&ecirc;n Windows Store v&agrave; cho ph&eacute;p m&ocirc; h&igrave;nh tự phục vụ, khả năng c&agrave;i đặt v&agrave; gỡ bỏ c&aacute;c ứng dụng sạch hơn, v&agrave; mở ra những m&ocirc; h&igrave;nh mới về cấp ph&eacute;p v&agrave; triển khai.</p><p>Một số nh&agrave; ph&acirc;n t&iacute;ch cho rằng c&aacute;c nh&agrave; ph&aacute;t triển phần mềm b&ecirc;n thứ ba sẽ quan t&acirc;m tới việc chuyển đổi ứng dụng desktop, v&igrave; nhờ đ&oacute; họ c&oacute; thể ph&acirc;n phối sản phẩm phần mềm cũ qua <a href="http://www.pcworld.com.vn/tags/?kw=Windows+Store">Windows Store</a> như với ứng dụng UWP. Desktop Bridge đem lại cho họ phương thức b&aacute;n h&agrave;ng mới theo xu hướng cửa h&agrave;ng ứng dụng, v&agrave; thực tế một số c&ocirc;ng ty như <a href="http://www.pcworld.com.vn/tags/?kw=Adobe">Adobe</a> chẳng hạn đ&atilde; c&oacute; sẵn ứng dụng Bridge tr&ecirc;n cửa h&agrave;ng. Kể cả với những nh&agrave; ph&aacute;t triển kh&ocirc;ng khai th&aacute;c khả năng kinh doanh từ Store th&igrave; vẫn được lợi trong việc sử dụng Desktop Bridge. C&aacute;c ứng dụng c&agrave;i đặt v&agrave; gỡ bỏ &ldquo;sạch&rdquo; hơn với c&aacute;c thư mục <a href="http://www.pcworld.com.vn/tags/?kw=Windows">Windows</a> v&agrave; registry ảo, việc sử dụng Bridge c&ograve;n cho ph&eacute;p nh&agrave; ph&aacute;t triển th&ecirc;m dần chức năng d&agrave;nh cho m&ocirc;i trường Windows 10, trong khi chương tr&igrave;nh vẫn chạy b&igrave;nh thường tr&ecirc;n <a href="http://www.pcworld.com.vn/tags/?kw=Windows+7">Windows 7</a>.&nbsp;</p><table class="ar-image-center" align="center" cellpadding="0" cellspacing="0"><tbody><tr><td><a class="lightbox-zoom" href="/files/articles/2017/1251727/h3-27-large.png" desc=""><img class="ar-photo" style="width: 600px; height=335px" src="/files/articles/2017/1251727/h3-27.png" alt=""></a></td></tr></tbody></table><p><strong>Mặt tr&aacute;i của Desktop Bridge</strong></p><p>Mặt tr&aacute;i của Desktop Bridge l&agrave; c&aacute;c nh&agrave; ph&aacute;t triển c&oacute; thể chỉ dừng lại với việc phủ lớp bọc l&ecirc;n ứng dụng của họ v&igrave; qu&aacute; tiện m&agrave; kh&ocirc;ng muốn tạo ứng dụng UWP thực sự. Điều đ&oacute; sẽ khiến ứng dụng UWP kh&oacute; phổ biến, bởi ứng dụng chuyển đổi sẽ kh&ocirc;ng chạy tr&ecirc;n điện thoại hay <a href="http://www.pcworld.com.vn/tags/?kw=laptop">laptop</a> Windows d&ugrave;ng chip <a href="http://www.pcworld.com.vn/tags/?kw=ARM">ARM</a> sắp xuất hiện.&nbsp;</p><p>Về ph&iacute;a Microsoft, h&atilde;ng chắc chắn sẽ t&igrave;m c&aacute;ch khuyến kh&iacute;ch c&aacute;c nh&agrave; ph&aacute;t triển kh&ocirc;ng chỉ đến với ứng dụng chuyển đổi m&agrave; tiến đến biến ch&uacute;ng th&agrave;nh ứng dụng UWP thực sự. Trước hết l&agrave; kết hợp một ứng dụng chuyển đổi với một tiến tr&igrave;nh UWP thứ hai, m&agrave; c&oacute; quyền truy cập tới c&aacute;c t&iacute;nh năng UWP, kiểu như chạy ở chế độ Connected Standby, m&agrave; tự th&acirc;n ứng dụng chuyển đổi kh&ocirc;ng thể l&agrave;m được. Adobe XD sử dụng kiểu kết hợp n&agrave;y; Ứng dụng XD được x&acirc;y dựng dạng UWP nhưng <a href="http://www.pcworld.com.vn/tags/?kw=Adobe">Adobe</a> c&ograve;n phủ l&ecirc;n c&aacute;c th&agrave;nh phần desktop từ c&aacute;c ứng dụng <a href="http://www.pcworld.com.vn/tags/?kw=Windows">Windows</a> hiện tại của h&atilde;ng như Photoshop bằng c&aacute;ch sử dụng Desktop Bridge do vậy XD c&oacute; thể chia sẻ ch&uacute;ng.</p><p>Với bản Creators Update, nhiều .NET v&agrave; Win32 API quen thuộc cũng c&oacute; sẵn cho ứng dụng UWP, do vậy rất dễ để chuyển đổi m&atilde; hiện tại sang UWP. Kevin Gallo, ph&oacute; chủ tịch nền tảng ph&aacute;t triển Windows của Microsoft cho biết, Microsoft đ&atilde; thay đổi c&aacute;c API hệ thống tập tin v&agrave; mạng. Tất nhi&ecirc;n ch&uacute;ng tốt hơn, nhưng điều đ&oacute; cũng c&oacute; nghĩa l&agrave; nh&agrave; ph&aacute;t triển phải cập nhật m&atilde; nguồn của họ hoặc lập tr&igrave;nh th&ecirc;m. Nếu vẫn sử dụng c&aacute;c h&agrave;m API cơ bản để x&acirc;y dựng ứng dụng v&agrave; đưa l&ecirc;n Store th&igrave; sẽ kh&ocirc;ng được chấp nhận.&nbsp;</p><p>V&agrave; như vậy, c&aacute;c API c&oacute; nhiều phi&ecirc;n bản sẽ lại g&acirc;y phiền phức hơn cho việc chuyển m&atilde;. Tuy nhi&ecirc;n Gallo hứa hẹn, Microsoft sẽ tiếp tục mở rộng c&aacute;c API m&agrave; ứng dụng UWP c&oacute; thể sử dụng để l&agrave;m ch&uacute;ng ph&ugrave; hợp hơn với m&atilde; nguồn hiện tại.</p><p>Theo Ginny Caughey, chủ tịch h&atilde;ng phần mềm Carolina Software v&agrave; cũng l&agrave; một chuy&ecirc;n gia MVP ph&aacute;t triển Windows, mục ti&ecirc;u cuối c&ugrave;ng l&agrave; chuyển hẳn sang ứng dụng UWP, nhưng &ocirc;ng băn khoăn kh&ocirc;ng r&otilde; thời gian sẽ mất bao l&acirc;u nữa. Doanh nghiệp thường chậm thay đổi, PC sẽ n&acirc;ng cấp l&ecirc;n Windows 10 nhưng kh&ocirc;ng phải tất cả ngay lập tức, do vậy UWP kh&ocirc;ng phải l&agrave; vấn đề cấp thiết. R&otilde; r&agrave;ng Microsoft đang tập trung đầu tư c&ocirc;ng nghệ mới v&agrave;o UWP, nhưng c&oacute; lẽ doanh nghiệp kh&ocirc;ng vội v&igrave; quan điểm l&acirc;u d&agrave;i trong kinh doanh.</p><p>Caughey cảnh b&aacute;o đang c&oacute; một số r&agrave;o cản kỹ thuật phần cứng đối với việc chuyển nhiều ứng dụng doanh nghiệp sang UWP; thiếu hỗ trợ SQL Server trực tiếp (SqlClient for UWP) l&agrave; khiếm khuyết lớn; thiếu c&aacute;c điều khiển UI (giao diện người d&ugrave;ng) doanh nghiệp như DataGrid cho UWP. D&ugrave; vậy, &ocirc;ng đ&aacute;nh gi&aacute; cao việc Microsoft mới đ&acirc;y đ&atilde; mở m&atilde; nguồn điều khiển Telerik UI cho UWP. Th&ecirc;m nữa c&ograve;n c&oacute; dự &aacute;n nguồn mở UWP Community Toolkit với sự t&agrave;i trợ của Microsoft trong khi chờ đợi Windows SDK ch&iacute;nh thức ra mắt sẽ cung cấp nhiều hơn những g&igrave; c&ograve;n thiếu.</p><p>Ứng dụng UWP hiện vẫn c&ograve;n qu&aacute; &iacute;t, tất cả vẫn đang chờ ph&iacute;a trước, v&agrave; c&oacute; lẽ phải tới năm 2020 khi Windows 10 phổ biến th&igrave; ứng dụng UWP mới cất c&aacute;nh, theo Puja Prabhakar, gi&aacute;m đốc cao cấp của Digital Workplace tại Avanade.</p><table class="ar-image-center" align="center" cellpadding="0" cellspacing="0"><tbody><tr><td><img class="ar-photo" style="width: 600px; height=338px" src="/files/articles/2017/1251727/h4-19.png" alt=""></td></tr></tbody></table><p><strong>Triển vọng c&ugrave;ng tablet</strong></p><p>Ứng dụng &lsquo;universal&rsquo;, viết một lần chạy tr&ecirc;n mọi thiết bị Windows 10, chưa hẳn đ&atilde; hấp dẫn doanh nghiệp, d&ugrave; về mặt l&yacute; thuyết kh&oacute; c&oacute; thể nghi ngờ về điều đ&oacute;, theo McQuire của h&atilde;ng ph&acirc;n t&iacute;ch CCS Insight. &Ocirc;ng cho rằng một số doanh nghiệp sẽ chuyển hẳn sang ứng dụng UWP, nhưng c&oacute; lẽ kh&ocirc;ng phải l&agrave; mục đ&iacute;ch để chạy tr&ecirc;n nhiều nền tảng thiết bị, từ di động, PC cho đến thiết bị đeo như tầm nh&igrave;n của Microsoft. C&oacute; chăng sự thu h&uacute;t của UWP l&agrave; ở sự tăng cường bảo mật v&agrave; khả năng quản l&yacute; m&agrave; n&oacute; cung cấp, đặc biệt l&agrave; với những ứng dụng quan trọng.&nbsp;</p><p>&ldquo;Về l&acirc;u d&agrave;i, nhiều người cũng sẽ theo d&otilde;i Windows 10 chạy tr&ecirc;n nền chip <a href="http://www.pcworld.com.vn/tags/?kw=ARM">ARM</a> v&agrave; <a href="http://www.pcworld.com.vn/tags/?kw=HoloLens">HoloLens</a> ph&aacute;t triển ra sao. Nhưng trước mắt, m&aacute;y để b&agrave;n sẽ tạo ra sự chuyển động nhanh nhất&rdquo;, &ocirc;ng n&oacute;i.</p><p>Caughey cũng chỉ ra rằng, tablet đang thay đổi c&aacute;ch doanh nghiệp nghĩ về di động. Ch&uacute;ng ta kh&ocirc;ng c&ograve;n lạ lẫm việc một số nơi thay thế m&aacute;y để b&agrave;n bằng m&aacute;y t&iacute;nh bảng hay thiết bị lai kiểu như Microsoft Surface ti&ecirc;n phong v&agrave; đang được một số nh&agrave; sản xuất OEM kh&aacute;c hưởng ứng. Ứng dụng UWP ph&aacute;t triển cho m&aacute;y t&iacute;nh để b&agrave;n, nhưng nhiều m&aacute;y trong ch&uacute;ng cũng sẽ l&agrave; thiết bị di động. Những thiết bị di động l&acirc;u đời như m&aacute;y b&aacute;n h&agrave;ng (POS) di động dựa tr&ecirc;n Windows CE hay <a href="http://www.pcworld.com.vn/tags/?kw=Windows+Mobile">Windows Mobile</a> đang dần bị thay thế bởi m&aacute;y t&iacute;nh bảng Windows gi&aacute; rẻ, l&agrave; những m&aacute;y chạy phi&ecirc;n bản Windows đầy đủ do vậy ch&uacute;ng cũng l&agrave; m&aacute;y t&iacute;nh để b&agrave;n nh&igrave;n từ g&oacute;c độ phần mềm. Xu hướng n&agrave;y c&oacute; lẽ sẽ th&agrave;nh chủ đạo nhờ những trải nghiệm c&ocirc;ng việc với iPad, nhưng m&aacute;y t&iacute;nh bảng Windows l&agrave; lựa chọn mặc nhi&ecirc;n trong nhiều doanh nghiệp l&acirc;u nay vốn đ&atilde; quen thuộc với hệ sinh th&aacute;i Windows.</p><p>Kleynhans của Gartner th&igrave; cho rằng sự hấp dẫn thực sự của ứng dụng UWP c&oacute; lẽ l&agrave; c&aacute;ch ch&uacute;ng c&oacute; thể tận dụng tối đa lợi thế của phần cứng mới, đặc biệt với Surface Dial v&agrave; <a href="http://www.pcworld.com.vn/tags/?kw=m%C3%A1y+t%C3%ADnh+b%E1%BA%A3ng">m&aacute;y t&iacute;nh bảng</a>, chứ kh&ocirc;ng phải c&aacute;c nền tảng &iacute;t phổ biến hơn kiểu như Surface Hub hay HoloLens.&nbsp;</p><p>N&uacute;m xoay Surface Dial c&oacute; c&aacute;ch tương t&aacute;c ho&agrave;n to&agrave;n mới hết sức độc đ&aacute;o. Đ&oacute; l&agrave; một thiết bị analog trong thế giới số m&agrave; theo Kleynhans sẽ mở ra nhiều cơ hội tuyệt vời cho c&ocirc;ng việc. Tất cả c&ograve;n chờ những ứng dụng UWP mới tạo đ&ograve;n bẩy v&agrave; sử dụng n&oacute; theo c&aacute;ch mới. Chẳng hạn quay b&agrave;n độ để chuyển đổi từ bản vẽ 2D sang 3D v&agrave; ngược lại trong khi xem kiến tr&uacute;c của một t&ograve;a nh&agrave;.</p><p>Kleynhans kỳ vọng những thiết bị 2-trong-1 như <a href="http://www.pcworld.com.vn/tags/?kw=Surface">Surface</a> v&agrave; Lenovo Yoga với m&agrave;n h&igrave;nh cảm ứng v&agrave; hỗ trợ b&uacute;t số sẽ th&uacute;c đẩy UWP phổ biến nhờ đem lại cho người d&ugrave;ng c&aacute;ch tương t&aacute;c mới với ứng dụng. H&atilde;y h&igrave;nh dung bạn chuyển ứng dụng chạy từ chế độ m&aacute;y t&iacute;nh sang tablet để ph&aacute;c họa c&ugrave;ng b&uacute;t số trong khi thơ thẩn trong kh&ocirc;ng gian l&agrave;m việc. Khả năng chạy được trong nhiều chế độ tr&ecirc;n c&ugrave;ng một thiết bị sẽ gi&uacute;p ứng dụng UWP cất c&aacute;nh khi doanh nghiệp l&agrave;m mới ứng dụng truyền thống để khai th&aacute;c thế mạnh của UWP.&nbsp;</p><p><a href="http://eshop.pcworld.com.vn/products/1429-kin-to-h-sinh-thi-cloud.aspx">PC World VN 05/2017</a></p>
		<div style="clear: both">
		</div>			
    </div>	
	
    
    <!--page list--->
    

    <table border="0" cellpadding="0" cellspacing="0" width="100%">
            <tr>				
                <td class="keyword" align="left">
					<table width="100%">
					<tr>
					<td colspan="2"><div class="keyword">Từ khóa: <a class="category-name" href="/tags/?kw=Microsoft">Microsoft</a>, <a class="category-name" href="/tags/?kw=Thương Huyền">Thương Huyền</a>, <a class="category-name" href="/tags/?kw=Universal Windows Platform">Universal Windows Platform</a>, <a class="category-name" href="/tags/?kw=Windows 10">Windows 10</a>, <a class="category-name" href="/tags/?kw=Windows 10 Creator">Windows 10 Creator</a></div></td>
					</tr>
					<tr>
					<td align="left" width="60%"></td>
					<td align="right" width="40%">
					</td>
					</tr>
					<tr><td colspan="2"><div class="source"><b>ID:&nbsp;</b>A1705_22</div></td></tr>
					</table>
                </td>
            </tr>
    </table>
	
	<!-- Ureka video -->
	<div id="uvideoarticle" align="center" style="padding-top: 10px; padding-bottom: 10px;"><iframe id="UrekaActicleVideo" width="1" height="1" frameborder="0" scrolling="no"></iframe></div>
	<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
	<script>
	  var googletag = googletag || {};
	  googletag.cmd = googletag.cmd || [];
	</script>

	<script>
	  googletag.cmd.push(function() {
		googletag.defineSlot('/2627062/articlevideo.pcworld.com.vn_1x1', [1, 1], 'div-gpt-ad-1499154862906-0').addService(googletag.pubads());
		googletag.pubads().enableSingleRequest();
		googletag.pubads().collapseEmptyDivs();
		googletag.enableServices();
	  });
	</script>
	<!-- /2627062/articlevideo.pcworld.com.vn_1x1 -->
	<div id='div-gpt-ad-1499154862906-0' style='height:1px; width:1px;'>
	<script>
	googletag.cmd.push(function() { googletag.display('div-gpt-ad-1499154862906-0'); });
	</script>
	</div>
	<!-- /Ureka video-->		
	
	<!-- Google adsense -->
	<div align="center" style="padding-top: 20px; padding-bottom: 20px;">
        <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
        <!-- pcworld-desktop-article-responsive -->
        <ins class="adsbygoogle"
             style="display:block"
             data-ad-client="ca-pub-1445831894229217"
             data-ad-slot="6569560482"
             data-ad-format="auto"></ins>
        <script>
        (adsbygoogle = window.adsbygoogle || []).push({});
        </script>
	</div>
	<!-- Google adsense -->		
	
	<!--start AddThis sharing-->
	<div class="addthis_native_toolbox" style="padding: 10px 0px 10px 0px"></div>
	<!--end Addthis sharing-->
	<!--start facebook social pluggin comment--->
    <div id="fb-root"></div> 
    <div class="fb-comments" href="http://www.pcworld.com.vn/articles/cong-nghe/2017/08/1251727/windows-10-va-tuong-lai-cua-ung-dung-uwp/" data-numposts="5" width="100%"></div>
    <!--end facebook social pluggin comment--->
	
    <!--end page list--->
    <div style="clear: both">
    </div>	
</div>



<script type="text/javascript" language="javascript">
    function popupImage(aUrl)
    {
        window.open(aUrl,"mywindow","menubar=0,toolbar=0,statusbar=0,resizable=1");
    }
    $('div.toolbar a.button').click(function(e) {
        if ($(e.target).hasClass('zoomplus')) {
            adjustTextSize('ar-content-html', +1);
            return false;
        }
        if ($(e.target).hasClass('zoomminus')) {
            adjustTextSize('ar-content-html', -1);
            return false;
        }
        if ($(e.target).hasClass('email')) {
            return pr_highslide_popup(e.target, 'Gởi E-mail');
        }
        if ($(e.target).hasClass('star')) {
            return pr_highslide_popup(e.target, 'Đưa vào danh sách ưa thích');
        }
        if ($(e.target).hasClass('printer')) {
            pr_show_print_version(e.target);
        } 
        return false;
    });
    $(function() {
        $('a.lightbox-zoom').click(function(e) {
            return hs.expand(this, {
                align: 'center',
                outlineType: 'rounded-white',
                fadeInOut: true,
                transitions: ['expand', 'crossfade'],
                captionText: $(this).attr('desc')
            });
        });
    });
	
</script>

<div align="center" style="padding-top:10px;padding-bottom:10px;">
<!--  ad tags Size: 468x60 ZoneId:1092865-->
<script type="text/javascript" src="http://js.medi-8.net/t/092/865/a1092865.js"></script>
</div>

<div class="related-ar-list-col-3">
    <div class="header-title">
        Tin bài cùng chuyên mục
    </div>
    <div class="list-area">
        <ul>
            
                    <li class="ar-list-item">
                        <a href="/articles/cong-nghe/2017/08/1251730/bo-xu-ly-do-hoa-gpu-tich-hop-khong-ngan-game/?utm_source=ar-related&utm_medium=referral&utm_campaign=relatednews">
                            <img src="/ic/a/d/w200h150f1c2-files-articles-2017-1251730.add.jpg" alt="Bộ xử lý đồ họa: GPU tích hợp không “ngán” game "  />
                        </a>
					    <div class="title">
						    <a href="/articles/cong-nghe/2017/08/1251730/bo-xu-ly-do-hoa-gpu-tich-hop-khong-ngan-game/?utm_source=ar-related&utm_medium=referral&utm_campaign=relatednews">
							    Bộ xử lý đồ họa: GPU tích hợp không “ngán” game 
						    </a>
					    </div>
				    </li>
                
                    <li class="ar-list-item">
                        <a href="/articles/cong-nghe/2017/06/1251556/windows-server-2016-nhieu-cai-tien-dang-gia/?utm_source=ar-related&utm_medium=referral&utm_campaign=relatednews">
                            <img src="/ic/a/d/w200h150f1c2-files-articles-2017-1251556.add.png" alt="Windows Server 2016 – nhiều cải tiến đáng giá"  />
                        </a>
					    <div class="title">
						    <a href="/articles/cong-nghe/2017/06/1251556/windows-server-2016-nhieu-cai-tien-dang-gia/?utm_source=ar-related&utm_medium=referral&utm_campaign=relatednews">
							    Windows Server 2016 – nhiều cải tiến đáng giá
						    </a>
					    </div>
				    </li>
                
                    <li class="ar-list-item">
                        <a href="/articles/cong-nghe/2017/05/1251560/nen-mua-hay-khong-nvidia-geforce-gtx-1080-ti/?utm_source=ar-related&utm_medium=referral&utm_campaign=relatednews">
                            <img src="/ic/a/d/w200h150f1c2-files-articles-2017-1251560.add-h1.png" alt="Nên mua hay không? NVIDIA GeForce GTX 1080 Ti "  />
                        </a>
					    <div class="title">
						    <a href="/articles/cong-nghe/2017/05/1251560/nen-mua-hay-khong-nvidia-geforce-gtx-1080-ti/?utm_source=ar-related&utm_medium=referral&utm_campaign=relatednews">
							    Nên mua hay không? NVIDIA GeForce GTX 1080 Ti 
						    </a>
					    </div>
				    </li>
                
                    <li class="ar-list-item">
                        <a href="/articles/cong-nghe/2017/04/1251482/5-loi-ich-cua-in-an-dam-may-doi-voi-doanh-nghiep/?utm_source=ar-related&utm_medium=referral&utm_campaign=relatednews">
                            <img src="/ic/3/0/w200h150f1c2-files-articles-2017-1251482.300.jpg" alt="5 lợi ích của in ấn đám mây đối với doanh nghiệp"  />
                        </a>
					    <div class="title">
						    <a href="/articles/cong-nghe/2017/04/1251482/5-loi-ich-cua-in-an-dam-may-doi-voi-doanh-nghiep/?utm_source=ar-related&utm_medium=referral&utm_campaign=relatednews">
							    5 lợi ích của in ấn đám mây đối với doanh nghiệp
						    </a>
					    </div>
				    </li>
                
                    <li class="ar-list-item">
                        <a href="/articles/cong-nghe/2017/04/1251455/5-meo-bao-mat-khi-dung-tai-khoan-microsoft/?utm_source=ar-related&utm_medium=referral&utm_campaign=relatednews">
                            <img src="/ic/5/0/w200h150f1c2-files-articles-2017-1251455.500(3).jpg" alt="5 mẹo bảo mật khi dùng tài khoản Microsoft"  />
                        </a>
					    <div class="title">
						    <a href="/articles/cong-nghe/2017/04/1251455/5-meo-bao-mat-khi-dung-tai-khoan-microsoft/?utm_source=ar-related&utm_medium=referral&utm_campaign=relatednews">
							    5 mẹo bảo mật khi dùng tài khoản Microsoft
						    </a>
					    </div>
				    </li>
                
                    <li class="ar-list-item">
                        <a href="/articles/cong-nghe/2017/04/1251436/5-thu-muc-bat-kha-xam-pham-cua-windows/?utm_source=ar-related&utm_medium=referral&utm_campaign=relatednews">
                            <img src="/ic/5/0/w200h150f1c2-files-articles-2017-1251436.500(3).jpg" alt="5 thư mục ‘bất khả xâm phạm’ của Windows"  />
                        </a>
					    <div class="title">
						    <a href="/articles/cong-nghe/2017/04/1251436/5-thu-muc-bat-kha-xam-pham-cua-windows/?utm_source=ar-related&utm_medium=referral&utm_campaign=relatednews">
							    5 thư mục ‘bất khả xâm phạm’ của Windows
						    </a>
					    </div>
				    </li>
                
                    <li class="ar-list-item">
                        <a href="/articles/cong-nghe/2017/03/1251172/5-cach-nhap-lieu-cuc-nhanh-tren-smartphone/?utm_source=ar-related&utm_medium=referral&utm_campaign=relatednews">
                            <img src="/ic/5/0/w200h150f1c2-files-articles-2017-1251172.500(2).jpg" alt="5 cách nhập liệu cực nhanh trên smartphone"  />
                        </a>
					    <div class="title">
						    <a href="/articles/cong-nghe/2017/03/1251172/5-cach-nhap-lieu-cuc-nhanh-tren-smartphone/?utm_source=ar-related&utm_medium=referral&utm_campaign=relatednews">
							    5 cách nhập liệu cực nhanh trên smartphone
						    </a>
					    </div>
				    </li>
                
                    <li class="ar-list-item">
                        <a href="/articles/cong-nghe/2017/03/1251210/4-cach-don-gian-de-chup-anh-ro-net-hon/?utm_source=ar-related&utm_medium=referral&utm_campaign=relatednews">
                            <img src="/ic/2/(/w200h150f1c2-files-articles-2017-1251210.2(1).jpg" alt="4 cách đơn giản để chụp ảnh rõ nét hơn"  />
                        </a>
					    <div class="title">
						    <a href="/articles/cong-nghe/2017/03/1251210/4-cach-don-gian-de-chup-anh-ro-net-hon/?utm_source=ar-related&utm_medium=referral&utm_campaign=relatednews">
							    4 cách đơn giản để chụp ảnh rõ nét hơn
						    </a>
					    </div>
				    </li>
                
                    <li class="ar-list-item">
                        <a href="/articles/cong-nghe/2017/02/1251086/doanh-nghiep-thoi-nay-khong-the-thieu-giai-phap-luu-tru-qua-mang/?utm_source=ar-related&utm_medium=referral&utm_campaign=relatednews">
                            <img src="/ic/q/n/w200h150f1c2-files-articles-2017-1251086.qnap.jpg" alt="Doanh nghiệp thời nay không thể thiếu giải pháp lưu trữ qua mạng"  />
                        </a>
					    <div class="title">
						    <a href="/articles/cong-nghe/2017/02/1251086/doanh-nghiep-thoi-nay-khong-the-thieu-giai-phap-luu-tru-qua-mang/?utm_source=ar-related&utm_medium=referral&utm_campaign=relatednews">
							    Doanh nghiệp thời nay không thể thiếu giải pháp lưu trữ qua mạng
						    </a>
					    </div>
				    </li>
                
        </ul>
    </div>
</div>
<div align="center" style="padding-top:10px;padding-bottom:10px;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- pcworld-ar-link-ads-responsive-02 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1445831894229217"
     data-ad-slot="1932444884"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

<div class="ar-latest">
    <div class="ar-latest-header">
        <span>Mới nhất</span>
    </div>
    <ul>
        
                <li>                    
					<a href="/articles/1252484/d-link-omna-180-cam-hd-camera-giam-sat-cho-nguoi-dung-iphone/?utm_source=ar-detail&utm_medium=referral&utm_campaign=latestnews"> D-Link Omna 180 Cam HD: Camera giám sát cho người dùng iPhone</a>
                </li>
            
                <li>                    
					<a href="/articles/1252486/ro-tin-blackberry-ra-mat-smartphone-chong-nuoc-trong-thang-10/?utm_source=ar-detail&utm_medium=referral&utm_campaign=latestnews"> Rộ tin BlackBerry ra mắt smartphone chống nước trong tháng 10</a>
                </li>
            
                <li>                    
					<a href="/articles/1251727/windows-10-va-tuong-lai-cua-ung-dung-uwp/?utm_source=ar-detail&utm_medium=referral&utm_campaign=latestnews"> Windows 10 và tương lai của ứng dụng UWP</a>
                </li>
            
                <li>                    
					<a href="/articles/1252288/khoi-dong-cuoc-thi-tim-hieu-kaspersky-2017/?utm_source=ar-detail&utm_medium=referral&utm_campaign=latestnews"> Khởi động Cuộc thi Tìm hiểu Kaspersky 2017</a>
                </li>
            
                <li>                    
					<a href="/articles/1251940/khoi-dong-giai-san-pham-cntt-tt-ua-chuong-nhat-2017/?utm_source=ar-detail&utm_medium=referral&utm_campaign=latestnews"> Khởi động Giải Sản phẩm CNTT-TT Ưa Chuộng Nhất 2017</a>
                </li>
            
        <div style="clear: both;">
        </div>
    </ul>
</div><div style="padding-top: 10px; padding-bottom: 10px;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- pcworld-matched-content-660x300 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:660px;height:300px"
     data-ad-client="ca-pub-1445831894229217"
     data-ad-slot="4154082882"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
                    <br />
                </li>
		
            </ul>
        </div>
        <div class="right">
            <div align="center" style="padding-top:0px; padding-bottom:10px;">
<div data-glade data-ad-unit-path="/218817569/pcworld.com.vn-article-300-250-01" height="250" width="300"></div>
<script async='async' src='https://securepubads.g.doubleclick.net/static/glade.js'></script>
</div><script type="text/javascript">
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement("script");
    gads.async = true;
    gads.type = "text/javascript";
    var useSSL = "https:" == document.location.protocol;
    gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
    var node =document.getElementsByTagName("script")[0];
    node.parentNode.insertBefore(gads, node);
   })();
</script>
<div id="div-gpt-ad-1327312723268-0" style="width:300px; height:250px;padding-bottom:10px;">
	<script type="text/javascript">
	googletag.cmd.push(function() {
	var slot1 = googletag.defineSlot("/218817569/pcworld.com.vn-article-300-250-03", [300, 250],
	"div-gpt-ad-1327312723268-0").addService(googletag.pubads());
	googletag.enableServices();
	googletag.display("div-gpt-ad-1327312723268-0");
	setInterval(function(){googletag.pubads().refresh([slot1]);}, 60000);
	});
	</script>
</div>

<div class="ar-list-click-max">
    <div class="header">
        ĐỌC NHIỀU CÙNG CHUYÊN MỤC
    </div>
    <ul>
    
            <li class="click-max-item">
                <div id="ctl00_ct_se_rd14_dl1_ctl00_Div1" class="img">
                    <a href="/articles/1251730/bo-xu-ly-do-hoa-gpu-tich-hop-khong-ngan-game/?utm_source=ar-detail&utm_medium=referral&utm_campaign=viewmostbycategory">
                        <img alt='Bộ xử lý đồ họa: GPU tích hợp không “ngán” game ' border="0" src="/ic/a/d/w100h75f1c2-files-articles-2017-1251730.add.jpg" />
                    </a>
                </div>
                <div class="title">
                    <a href="/articles/1251730/bo-xu-ly-do-hoa-gpu-tich-hop-khong-ngan-game/?utm_source=ar-detail&utm_medium=referral&utm_campaign=viewmostbycategory">
                        Bộ xử lý đồ họa: GPU tích hợp không “ngán” game </a>
                </div>
                <div style="clear: both;">
                </div>
            </li>
        
            <li class="click-max-item">
                <div id="ctl00_ct_se_rd14_dl1_ctl01_Div1" class="img">
                    <a href="/articles/1251727/windows-10-va-tuong-lai-cua-ung-dung-uwp/?utm_source=ar-detail&utm_medium=referral&utm_campaign=viewmostbycategory">
                        <img alt='Windows 10 và tương lai của ứng dụng UWP' border="0" src="/ic/u/w/w100h75f1c2-files-articles-2017-1251727.uwp-apps.png" />
                    </a>
                </div>
                <div class="title">
                    <a href="/articles/1251727/windows-10-va-tuong-lai-cua-ung-dung-uwp/?utm_source=ar-detail&utm_medium=referral&utm_campaign=viewmostbycategory">
                        Windows 10 và tương lai của ứng dụng UWP</a>
                </div>
                <div style="clear: both;">
                </div>
            </li>
        
    </ul>
</div>
<div align="center" style="padding-bottom:10px;">
<div data-glade data-ad-unit-path="/218817569/pcworld.com.vn-article-300-250-02" height="250" width="300"></div>
<script async='async' src='https://securepubads.g.doubleclick.net/static/glade.js'></script>
</div>

<div class="ar-list-viewmost">
    <div class="header">            
        ĐỌC NHIỀU TRONG TUẦN
    </div>
    <ul>
		
			<li>
				<a href='/articles/cong-nghe/song-va-cong-nghe/2017/08/1251940/khoi-dong-giai-san-pham-cntt-tt-ua-chuong-nhat-2017/?utm_source=homepage&utm_medium=referral&utm_campaign=readmost'>
						Khởi động Giải Sản phẩm CNTT-TT Ưa Chuộng Nhất 2017
				</a>
			</li>
		
			<li>
				<a href='/articles/cong-nghe/song-va-cong-nghe/2017/08/1252288/khoi-dong-cuoc-thi-tim-hieu-kaspersky-2017/?utm_source=homepage&utm_medium=referral&utm_campaign=readmost'>
						Khởi động Cuộc thi Tìm hiểu Kaspersky 2017
				</a>
			</li>
		
			<li>
				<a href='/articles/preview/2017/08/1252430/galaxy-j3-pro-smartphone-nho-nhung-co-vo/?utm_source=homepage&utm_medium=referral&utm_campaign=readmost'>
						Galaxy J3 Pro - smartphone nhỏ, nhưng có võ
				</a>
			</li>
		
			<li>
				<a href='/articles/preview/2017/08/1252451/moto-c-plus-smartphone-cuc-ngon-trong-tam-gia-pho-thong/?utm_source=homepage&utm_medium=referral&utm_campaign=readmost'>
						Moto C Plus – smartphone 'CỰC NGON' trong tầm giá phổ thông
				</a>
			</li>
		
			<li>
				<a href='/articles/san-pham/di-dong/2017/08/1252476/smartphone-pin-khung-xiaomi-mi-max-2-gia-5-99-trieu-dong/?utm_source=homepage&utm_medium=referral&utm_campaign=readmost'>
						Smartphone pin khủng Xiaomi Mi Max 2 giá 5,99 triệu đồng
				</a>
			</li>
		
			<li>
				<a href='/articles/san-pham/may-xach-tay/2017/08/1252456/hp-chinh-thuc-mo-ban-laptop-pavilion-cho-mua-tuu-truong/?utm_source=homepage&utm_medium=referral&utm_campaign=readmost'>
						HP chính thức mở bán laptop Pavilion cho mùa tựu trường
				</a>
			</li>
		
			<li>
				<a href='/articles/kinh-doanh/giai-phap/2017/08/1252466/lua-chon-vpn-draytek-cho-doanh-nghiep/?utm_source=homepage&utm_medium=referral&utm_campaign=readmost'>
						Lựa chọn VPN DrayTek cho doanh nghiệp
				</a>
			</li>
		
			<li>
				<a href='/articles/san-pham/di-dong/2017/08/1252464/samsung-galaxy-note-8-mo-ban-tu-giua-thang-9-2017-co-4-mau/?utm_source=homepage&utm_medium=referral&utm_campaign=readmost'>
						Samsung Galaxy Note 8 mở bán từ giữa tháng 9/2017, có 4 màu
				</a>
			</li>
		
			<li>
				<a href='/articles/cong-nghe/2017/08/1251730/bo-xu-ly-do-hoa-gpu-tich-hop-khong-ngan-game/?utm_source=homepage&utm_medium=referral&utm_campaign=readmost'>
						Bộ xử lý đồ họa: GPU tích hợp không “ngán” game 
				</a>
			</li>
		
			<li>
				<a href='/articles/san-pham/may-xach-tay/2017/08/1252473/lenovo-ideapad-320-phien-ban-bxl-amd-gia-tu-8-5-trieu-dong/?utm_source=homepage&utm_medium=referral&utm_campaign=readmost'>
						Lenovo IdeaPad 320 phiên bản BXL AMD giá từ 8,5 triệu đồng
				</a>
			</li>
		
        <div style="clear: both;">
        </div>
    </ul>
</div>

<div class="ar-list-click-max">

    <ul>
    
            <li class="click-max-item">
                <div id="ctl00_ct_se_rd23_dl1_ctl00_Div1" class="img">
                    <a href="/articles/1250408/bo-suu-tap-man-hinh-pc-co-mot-khong-hai/?utm_source=homepage&utm_medium=referral&utm_campaign=editorpick">
                        <img alt='Bộ sưu tập màn hình PC 'có một không hai'' border="0" src="/ic/i/m/w100h75f1c2-files-articles-2016-1250408.image3-large(1).jpeg" />
                    </a>
                </div>
                <div class="title">
                    <a href='/articles/1250408/bo-suu-tap-man-hinh-pc-co-mot-khong-hai/?utm_source=homepage&utm_medium=referral&utm_campaign=editorpick'>Bộ sưu tập màn hình PC 'có một không hai'</a>
                </div>
                <div style="clear: both;">
                </div>
            </li>
        
            <li class="click-max-item">
                <div id="ctl00_ct_se_rd23_dl1_ctl01_Div1" class="img">
                    <a href="/articles/1250595/sang-trong-va-lich-lam-voi-dong-laptop-moi-manh-me-cua-hp/?utm_source=homepage&utm_medium=referral&utm_campaign=editorpick">
                        <img alt='Sang trọng và lịch lãm với dòng laptop mới mạnh mẽ của HP' border="0" src="/ic/d/a/w100h75f1c2-files-articles-2016-1250595.daidien-400.jpg" />
                    </a>
                </div>
                <div class="title">
                    <a href='/articles/1250595/sang-trong-va-lich-lam-voi-dong-laptop-moi-manh-me-cua-hp/?utm_source=homepage&utm_medium=referral&utm_campaign=editorpick'>Sang trọng và lịch lãm với dòng laptop mới mạnh mẽ của HP</a>
                </div>
                <div style="clear: both;">
                </div>
            </li>
        
            <li class="click-max-item">
                <div id="ctl00_ct_se_rd23_dl1_ctl02_Div1" class="img">
                    <a href="/articles/1250651/danh-gia-may-in-canon-pixma-g4000/?utm_source=homepage&utm_medium=referral&utm_campaign=editorpick">
                        <img alt='Đánh giá máy in Canon PIXMA G4000' border="0" src="/ic/h/i/w100h75f1c2-files-articles-2016-1250651.hinh1.jpg" />
                    </a>
                </div>
                <div class="title">
                    <a href='/articles/1250651/danh-gia-may-in-canon-pixma-g4000/?utm_source=homepage&utm_medium=referral&utm_campaign=editorpick'>Đánh giá máy in Canon PIXMA G4000</a>
                </div>
                <div style="clear: both;">
                </div>
            </li>
        
            <li class="click-max-item">
                <div id="ctl00_ct_se_rd23_dl1_ctl03_Div1" class="img">
                    <a href="/articles/1250709/an-tuong-voi-laptop-doanh-nhan-sieu-nhe-hp-elitebook-1030-g1/?utm_source=homepage&utm_medium=referral&utm_campaign=editorpick">
                        <img alt='Ấn tượng với laptop doanh nhân siêu nhẹ HP EliteBook 1030 G1' border="0" src="/ic/d/a/w100h75f1c2-files-articles-2016-1250709.daidien-800.jpg" />
                    </a>
                </div>
                <div class="title">
                    <a href='/articles/1250709/an-tuong-voi-laptop-doanh-nhan-sieu-nhe-hp-elitebook-1030-g1/?utm_source=homepage&utm_medium=referral&utm_campaign=editorpick'>Ấn tượng với laptop doanh nhân siêu nhẹ HP EliteBook 1030 G1</a>
                </div>
                <div style="clear: both;">
                </div>
            </li>
        
            <li class="click-max-item">
                <div id="ctl00_ct_se_rd23_dl1_ctl04_Div1" class="img">
                    <a href="/articles/1250757/kinh-nghiem-vang-lua-chon-laptop-cho-sinh-vien/?utm_source=homepage&utm_medium=referral&utm_campaign=editorpick">
                        <img alt='Kinh nghiệm 'vàng' lựa chọn laptop cho sinh viên' border="0" src="/ic/a/b/w100h75f1c2-files-articles-2016-1250757.ab-0057-01-web.jpg" />
                    </a>
                </div>
                <div class="title">
                    <a href='/articles/1250757/kinh-nghiem-vang-lua-chon-laptop-cho-sinh-vien/?utm_source=homepage&utm_medium=referral&utm_campaign=editorpick'>Kinh nghiệm 'vàng' lựa chọn laptop cho sinh viên</a>
                </div>
                <div style="clear: both;">
                </div>
            </li>
        
            <li class="click-max-item">
                <div id="ctl00_ct_se_rd23_dl1_ctl05_Div1" class="img">
                    <a href="/articles/1250862/may-in-tiet-kiem-chi-phi-cho-doanh-nghiep/?utm_source=homepage&utm_medium=referral&utm_campaign=editorpick">
                        <img alt='Máy in tiết kiệm chi phí cho doanh nghiệp' border="0" src="/ic/d/a/w100h75f1c2-files-articles-2017-1250862.daidien.jpg" />
                    </a>
                </div>
                <div class="title">
                    <a href='/articles/1250862/may-in-tiet-kiem-chi-phi-cho-doanh-nghiep/?utm_source=homepage&utm_medium=referral&utm_campaign=editorpick'>Máy in tiết kiệm chi phí cho doanh nghiệp</a>
                </div>
                <div style="clear: both;">
                </div>
            </li>
        
    </ul>
</div><div align="center" style="padding-bottom:10px;">
<!--  ad tags Size: 300x250 ZoneId:1107216-->
<script type="text/javascript" src="http://js.genieessp.com/t/107/216/a1107216.js"></script>
</div>
        </div>
        <div style="clear:both"></div>
    </div>
    <div class="content-3">
        <div align="center" style="padding-top:10px;padding-bottom:10px;background-color:#ffffff;"><div data-glade data-ad-unit-path="/218817569/pcworld-article-970-90-01" height="90" width="970"></div>
<script async='async' src='https://securepubads.g.doubleclick.net/static/glade.js'></script></div>

<ul class="line-box-rounder">
    <li class="ct">
        <div style="color: #2e2e2e; font-size: 16px; font-weight: bold; border-bottom: solid 3px #dd0301;
            padding-bottom: 3px; margin-bottom: 10px">
            CHUYÊN ĐỀ
        </div>
        <table border="0" cellpadding="4" cellspacing="0" width="100%">
            <tr>
                
                        <td width="24.5%" valign="top" align="center">
                            <div style="text-align: center; margin-top: 10px;">
                                <a href='/articles/cong-nghe/an-ninh-mang/2016/11/1250375/bao-mat-he-thong/?utm_source=ar-detail&utm_medium=referral&utm_campaign=chuyende' style="color: #d40400">
                                    <img style="border: solid 1px #c0c0c0; padding: 1px" alt='Bảo mật hệ thống' src='/ic/c/o/w145h109f0c2-files-articles-2016-1250375.cover-cd.jpg'
                                        border="0" />
                                </a>
                            </div>	
							<div style="text-align: center; margin-top: 10px;">
                            <a href='/articles/cong-nghe/an-ninh-mang/2016/11/1250375/bao-mat-he-thong/?utm_source=ar-detail&utm_medium=referral&utm_campaign=chuyende' style="color: #d40400">
                                Bảo mật hệ thống
                            </a>
							</div>
                        </td>
                    
                        <td style="border-left: solid 1px #cecece; width: 0.5%">
                        </td>
                    
                        <td width="24.5%" valign="top" align="center">
                            <div style="text-align: center; margin-top: 10px;">
                                <a href='/articles/cong-nghe/cong-nghe/2016/10/1250374/thoi-cua-drone/?utm_source=ar-detail&utm_medium=referral&utm_campaign=chuyende' style="color: #d40400">
                                    <img style="border: solid 1px #c0c0c0; padding: 1px" alt='Thời của Drone' src='/ic/b/i/w145h109f0c2-files-articles-2016-1250374.bia-a1608-1024-sm.jpg'
                                        border="0" />
                                </a>
                            </div>	
							<div style="text-align: center; margin-top: 10px;">
                            <a href='/articles/cong-nghe/cong-nghe/2016/10/1250374/thoi-cua-drone/?utm_source=ar-detail&utm_medium=referral&utm_campaign=chuyende' style="color: #d40400">
                                Thời của Drone
                            </a>
							</div>
                        </td>
                    
                        <td style="border-left: solid 1px #cecece; width: 0.5%">
                        </td>
                    
                        <td width="24.5%" valign="top" align="center">
                            <div style="text-align: center; margin-top: 10px;">
                                <a href='/articles/cong-nghe/cong-nghe/2016/08/1249241/khai-thac-windows-10/?utm_source=ar-detail&utm_medium=referral&utm_campaign=chuyende' style="color: #d40400">
                                    <img style="border: solid 1px #c0c0c0; padding: 1px" alt='Khai thác Windows 10' src='/ic/k/h/w145h109f0c2-files-articles-2016-1249241.khai-thac-win-10.jpg'
                                        border="0" />
                                </a>
                            </div>	
							<div style="text-align: center; margin-top: 10px;">
                            <a href='/articles/cong-nghe/cong-nghe/2016/08/1249241/khai-thac-windows-10/?utm_source=ar-detail&utm_medium=referral&utm_campaign=chuyende' style="color: #d40400">
                                Khai thác Windows 10
                            </a>
							</div>
                        </td>
                    
                        <td style="border-left: solid 1px #cecece; width: 0.5%">
                        </td>
                    
                        <td width="24.5%" valign="top" align="center">
                            <div style="text-align: center; margin-top: 10px;">
                                <a href='/articles/cong-nghe/song-va-cong-nghe/2016/07/1249042/chuan-bi-du-lich-he/?utm_source=ar-detail&utm_medium=referral&utm_campaign=chuyende' style="color: #d40400">
                                    <img style="border: solid 1px #c0c0c0; padding: 1px" alt='Chuẩn bị du lịch hè' src='/ic/b/i/w145h109f0c2-files-articles-2016-1249042.bia-a1606-1024.jpg'
                                        border="0" />
                                </a>
                            </div>	
							<div style="text-align: center; margin-top: 10px;">
                            <a href='/articles/cong-nghe/song-va-cong-nghe/2016/07/1249042/chuan-bi-du-lich-he/?utm_source=ar-detail&utm_medium=referral&utm_campaign=chuyende' style="color: #d40400">
                                Chuẩn bị du lịch hè
                            </a>
							</div>
                        </td>
                    
                        <td style="border-left: solid 1px #cecece; width: 0.5%">
                        </td>
                    
                        <td width="24.5%" valign="top" align="center">
                            <div style="text-align: center; margin-top: 10px;">
                                <a href='/articles/cong-nghe/cong-nghe/2016/06/1248631/van-phong-thong-minh/?utm_source=ar-detail&utm_medium=referral&utm_campaign=chuyende' style="color: #d40400">
                                    <img style="border: solid 1px #c0c0c0; padding: 1px" alt='Văn phòng thông minh' src='/ic/b/i/w145h109f0c2-files-articles-2016-1248631.bia-a160-800-smal.jpg'
                                        border="0" />
                                </a>
                            </div>	
							<div style="text-align: center; margin-top: 10px;">
                            <a href='/articles/cong-nghe/cong-nghe/2016/06/1248631/van-phong-thong-minh/?utm_source=ar-detail&utm_medium=referral&utm_campaign=chuyende' style="color: #d40400">
                                Văn phòng thông minh
                            </a>
							</div>
                        </td>
                    
            </tr>
        </table>
        <br />
        <br />
    </li>
</ul>

    </div>
</div>


<div style="clear: both">
</div>

<div class="add_this_recommended_content_footer">
</div>

<div style="clear: both">
</div>

<div class="footer">
    <div class="ver-footer-mnu">
        <a href="/">Trang chủ</a>| <a href="/pages/thong-tin-toa-soan/">Giới thiệu</a>|
        <a href="/lien-he/">Liên hệ</a>| <a href="http://eshop.pcworld.com.vn">Đặt Mua Tạp Chí</a>|
        <a href="/quang-cao/">Quảng cáo</a> | <a href="/articles/game/">Thế Giới Game</a>
    </div>
    <br />
    <div style="text-align: center; color: #fefefe; font-size: 11px">
        &copy; Bản quyền của Tạp chí Thế Giới Vi Tính - PC World VN | Cơ quan chủ quản: Sở Khoa học và Công nghệ TP.HCM<br />
        Giấy phép (1) số 196/GP-BVHTT do Bộ Văn hóa Thông tin cấp ngày 27-06-2003<br />
        Giấy phép (2) số 202/GP-BC do Bộ Thông tin và Truyền thông - Cục Báo chí cấp ngày 05-05-2008<br />
        Tòa soạn: Lầu 5, 79 Trương Định, Phường Bến Thành, Quận 1, TP. HCM - ĐT: (08) 38 257 745<br /><br />
        <br />
    </div>
</div>


            </div>
        </div>
    

<script type="text/javascript">
//<![CDATA[
Sys.Application.initialize();
//]]>
</script>
</form>

	
	<!--start facebook javascript sdk-->
	<div id="fb-root"></div>
	<script>
		window.fbAsyncInit = function () {
			FB.init({
				appId: '335545929956156',
				xfbml: true,
				version: 'v2.3'
			});
		};

		(function (d, s, id) {
			var js, fjs = d.getElementsByTagName(s)[0];
			if (d.getElementById(id)) { return; }
			js = d.createElement(s); js.id = id;
			js.src = "//connect.facebook.net/vi_VN/sdk.js";
			fjs.parentNode.insertBefore(js, fjs);
		} (document, 'script', 'facebook-jssdk'));
	</script>
	<!--end facebook javascript sdk-->
	<!-- Facebook Pixel Code -->
	<script>
	!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
	n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
	n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
	t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
	document,'script','//connect.facebook.net/en_US/fbevents.js');

	fbq('init', '1651841478394856');
	fbq('track', "PageView");</script>
	<noscript><img height="1" width="1" style="display:none"
	src="https://www.facebook.com/tr?id=1651841478394856&ev=PageView&noscript=1"
	/></noscript>
	<!-- End Facebook Pixel Code -->
	
	<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4e325dd1349e68c1" async="async"></script>

</body>
</html>
