• Thứ Năm, 16/04/2009 11:32 (GMT+7)

    Mozilla cân nhắc ngừng hỗ trợ Firefox cho Win2K, XP

    Mozilla đang cân nhắc sẽ ngừng hỗ trợ cho Windows 2000 và những phiên bản XP đầu tiên vào năm 2010 sau khi tung ra Firefox 3.5.

    Theo những trao đổi trên diễn đàn Mozilla.dev.planning, các nhà phát triển và giới lãnh đạo Mozilla (bao gồm cả giám đốc kỹ thuật công ty và giám đốc Firefox) đang băn khoăn là liệu phiên bản trình duyệt “chào đời” trong năm 2010 nên hỗ trợ những HĐH nào của Microsoft.

    Kỹ sư phần mềm Michael Conner cho biết, yêu cầu tối thiểu của engine Gecko 1.9.2 (và bất kỳ phiên bản Firefox nào được xây dựng trên 1.9.2) là Windows XP Service Pack 3 hoặc cao hơn. Hiện Mozilla đang làm việc trên Gecko 1.9.1 - engine được sử dụng trong Firefox 3.5 (dự kiến sẽ được phát hành trong quý II/2009). Theo kế hoạch, Gecko 1.9.2 và trình duyệt “hậu bối” của Firefox 3.5 được xây dựng trên engine này (mà Mozilla gọi là “Firefox.next” và tên mã là “Namoroka”) sẽ trình làng vào giữa năm 2010.

    Đề xuất của ông Conner dựa trên thực tế là Microsoft sẽ chấm dứt tất cả hỗ trợ cho Windows 2000, Windows XP Service Pack 2 vào ngày 13/7/2010 và đã ngừng hỗ trợ cho Windows XP, Windows XP SP1. Sau thời hạn tháng 7/2010, Microsoft sẽ chỉ hỗ trợ cho Windows XP SP3.

    Tuy nhiên, nhà phát triển Rob Arnold cho rằng nên đợi xem mọi chuyện sẽ diễn biến thế nào sau khi Windows 7 trình làng rồi hãy quyết định. Nếu mọi người có xu hướng chuyển từ XP lên Windows 7 thì hãy tính đến chuyện ngừng hỗ trợ XP.

    Sau khi Firefox.next trình làng, Firefox 3.5 sẽ tiếp tục được hỗ trợ theo chính sách hiện nay cho tới khi những phiên bản HĐH này không còn được hỗ trợ nữa. hiện tại, Firefox 3.08 (và sắp tới là Firefox 3.5) hỗ trợ Windows 2000/XP/Vista/Server 2003. Các HĐH cũ của Microsoft (Windows 98, Windows NT) đã không thể nâng cấp từ Firefox 2.0 lên dòng Firefox 3.x.

    Bạch Đình Vinh
    Theo Computerworld, 14/4/2009

    ID: O0904_1